Banner Ad 1

Engel 212 glitching issue with tank controller

R/C Submarine modelers

Engel 212 glitching issue with tank controller

Postby fgroza » Tue Aug 09, 2011 9:27 pm

This problem became public when Dave Welch tried to run his 212. The "glitch" is in the tank controller board, as seen by a electrical engineer. When you try to extend the piston to pull water into the tank, it starts then stops almost instantly. If you physically move the gearing by hand so that the jackscrew is out about 1/2" it will work. However, if you retract it completly it goes back into the glitch mode. Tried moving micro switches, ground off the tip of the micro switch plunger with no great results. Dave went to the proportional setup and has had great results. Engel has not returned a answer to my inquiry about this but it may take some time.
Overall the sub runs great and looks killer in the water. I was just wandering if anyone else has this problem.
Thanks
Frank Groza
Image

Image

photos by Jim Henson
User avatar
fgroza
Registered User
 
Posts: 175
Joined: Sat Jun 25, 2005 6:37 pm
Location: Byesville, Ohio

Re: Engel 212 glitching issue with tank controller

Postby Wheelerdealer » Wed Aug 10, 2011 2:57 pm

Disconnect the pressure sensor from the piston control tank board or wrap the leads around a ferrite ring and all will be well.
You could try rerouting the pressure sensor wires some other way but thats normally more effort.
Ramesh
www.rcmodelsubmarines.co.uk
----------------------------------------------------
Whaddya mean, I need a license to do that?!
User avatar
Wheelerdealer
SubCommittee Member
 
Posts: 284
Joined: Thu Jun 22, 2006 1:45 pm
Location: London, UK

Re: Engel 212 glitching issue with tank controller

Postby Bigdave » Wed Aug 10, 2011 3:39 pm

Hi Ramesh,
Just curious how the pressure sensor would effect the board.
I still use it on my propo board and it has no issues.
That is one thing I never tried before I took out the stock board.
I am much happier with the propo board anyway. 8)
Color me confused!! :? BD.
BTW-Frank I found my leak in the 212.
The epoxy I used to install the motor bulkhead never hardened correctly and turned to soft stickey goo!! :twisted: :twisted: :evil: :evil: :evil:
I can't get it out with the ring installed so I have to scrape it out from the inside so I can add the correct epoxy.
AAAARRRGGGGGGG!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :evil: :x :x
That is the last time I use this C##P!! :cry: :cry: :cry: BD.
David Welch
Commodore SR-8

Image


"Eat your pudding Mr Land". "I ain't sure it's puddin" James Mason-Kirk
Douglas, 20K
User avatar
Bigdave
SubCommittee Member
 
Posts: 2846
Joined: Fri Feb 21, 2003 8:33 am
Location: Rochester NY

Re: Engel 212 glitching issue with tank controller

Postby Wheelerdealer » Wed Aug 10, 2011 4:50 pm

Hi Dave, I have no idea why it would effect it :oops: Clearly its the position or lenght of the wiring affects the new controller board, as in the latest German instruction maunal they instruct you to fit a ferrite ring to the wiring to reduce noise...

"7.7 Um Störeinflüsse auf das DS-Anschlusskabel zu verringern,
die zum Druckschalter liegenden Kabelenden min. dreimal
durch den beilienden, blauen Ferritring führen (siehe Bild)."
Ramesh
www.rcmodelsubmarines.co.uk
----------------------------------------------------
Whaddya mean, I need a license to do that?!
User avatar
Wheelerdealer
SubCommittee Member
 
Posts: 284
Joined: Thu Jun 22, 2006 1:45 pm
Location: London, UK

Re: Engel 212 glitching issue with tank controller

Postby Bigdave » Wed Aug 10, 2011 5:34 pm

Must have been a problem that kept showing up. Glad they tracked it down.
Thanks for the info.
Hopefully Frank will give it a try and see if it helps. :mrgreen:
The ball is in your court buddy!! :lol:
Go Frank Go!! :D BD.
David Welch
Commodore SR-8

Image


"Eat your pudding Mr Land". "I ain't sure it's puddin" James Mason-Kirk
Douglas, 20K
User avatar
Bigdave
SubCommittee Member
 
Posts: 2846
Joined: Fri Feb 21, 2003 8:33 am
Location: Rochester NY

Re: Engel 212 glitching issue with tank controller

Postby fgroza » Wed Aug 10, 2011 6:54 pm

Dave,
There was a ferrite ring of about 1/2" dia included in the kit. No explanation of what it was for though. I'm going to the shop to wrap some wire!!
I'll let you know if it works. I still like the dial a depth idea.
Frank
User avatar
fgroza
Registered User
 
Posts: 175
Joined: Sat Jun 25, 2005 6:37 pm
Location: Byesville, Ohio

Re: Engel 212 glitching issue with tank controller

Postby fgroza » Wed Aug 10, 2011 8:38 pm

Ramesh is the winner!! So far, no more glitches when retracted. Hope it works in the pond.
Frank
User avatar
fgroza
Registered User
 
Posts: 175
Joined: Sat Jun 25, 2005 6:37 pm
Location: Byesville, Ohio


Return to R/C Modeler

Who is online

Users browsing this forum: PaulC